Relaunch signal not sent to apps (Bug #1011)


Added by Herman van Hazendonk about 2 years ago. Updated almost 2 years ago.


Status:Closed Start date:02/22/2015
Priority:Normal Due date:
Assignee:Christophe Chapuis % Done:

100%

Category:Applications
Target version:Medici

Description

Tofe: Just re-adding this one since it still persists in current release, and it might be related to the app menu issue we're having for noWindow apps.

Contacts listens to the relaunch signal that LunaBindings.js sends when Mojo.relaunch() is called. Under Breve, this was sent. Under Americano, it is not.

To reproduce
1) Launch Contacts
2) On the command line, enter
luna-send -n 1 palm://com.palm.applicationManager/open '{"id": "com.palm.app.contacts", "params": {"launchType": "newContact", "contact": {"nickname": "Johnny"}}}'

Expected result: Contacts switches to the "Create New Contact" pane.

Actual result: nothing happens


Issue hierarchy

Bug #1005: QtWebEngine Migration CleanupClosedChristophe Chapuis

Bug #1011: Relaunch signal not sent to appsClosedChristophe Chapuis


History

Updated by Doug Reeder about 2 years ago

This first manifested under Americano. It did not occur under Breve. (See http://issues.webos-ports.org/issues/867).

I confirmed this happening on the N4 with the 07-Nov-2015 testing build and the TP with the 02-Nove testing build.

Updated by Doug Reeder about 2 years ago

If Contacts is not running when you issue the luna-send command, it correctly displays the Create New Contact pane (using a different mechanism than Mojo.relaunch()).

If a different app is maximized when you issue luna-send command, Contacts is maximized (i.e. it is relaunched, but it doesn't know it's been relaunched).

If the device is in card mode when the luna-send command is issued, nothing visible happens.

If Contacts is maximized when the luna-send command is issued, nothing visible happens.

Updated by Herman van Hazendonk about 2 years ago

Focus issue is now solved, the relaunch is still not handled properly.

  • % Done changed from 0 to 50
  • Status changed from New to In Progress

Updated by Christophe Chapuis almost 2 years ago

It looks like there are two mistakes in Contacts (in source/views/views.js)
1. the event is onwebOSRelaunch, not onrelaunch
2. it is not "e" that contains the parameters, but "e.detail"

However I am surprised that it worked before, as these things shouldn't have changed for a while

Updated by Herman van Hazendonk almost 2 years ago

Behavior for App Menu is OK: If app not in focus, focus app. When app is focused it'll show app menu.

Legacy does it the same.

For: luna-send -n 1 palm://com.palm.applicationManager/open '{"id": "com.palm.app.contacts", "params": {"launchType": "newContact", "contact": {"nickname": "Johnny"}}}'
It should chain when not focused: 1. focus app, 2. maximize card, 3. show new contact dialog

  • % Done changed from 50 to 80
  • Category set to Applications

Updated by Doug Reeder almost 2 years ago

The problem was that webos-lib defines Mojo.relaunch() such that onrelaunch is sent, while enyo-webos defines it such that onwebOSRelaunch is sent. In the medium-term, we need to remove this functionality from webos-lib.

I can confirm that this is fixed by https://github.com/webOS-ports/org.webosports.app.contacts/pull/17 in luneos-dev-package-mako-20151125094906-testing-0-277.zip

Updated by Herman van Hazendonk almost 2 years ago

  • Target version changed from Marocchino to Medici

Updated by Herman van Hazendonk almost 2 years ago

  • % Done changed from 80 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF