Content

Support #1047

Migrate from BlueZ 4 to BlueZ 5

Added by Herman van Hazendonk over 3 years ago. Updated about 1 month ago.

Status:Closed Start date:01/21/2016
Priority:Normal Due date:
Assignee:Christophe Chapuis % Done:

100% Total progress

Category:OpenEmbedded
Target version:Decaf

Description

With BlueZ 4 no longer being maintained and BlueZ 5 being around for a while already, ConnMan will drop BlueZ 4 support with 1.32 as per https://01.org/connman/blogs/pflykt/2015/connman-1.31

Necessary to upgrade our stack.


Issue Hierarchy ()

History

Updated by Herman van Hazendonk over 3 years ago

  • Assignee changed from Martin Jansa to Christophe Chapuis

Updated by Herman van Hazendonk over 3 years ago

Seems we'll require kernel 3.4 for this. So this will probably not be viable anytime soon.

Updated by Herman van Hazendonk over 3 years ago

Might be possible with older kernel too, but might require some work. Ubuntu guys have documented it:

https://wiki.ubuntu.com/Touch/BluetoothEnablement

Updated by Herman van Hazendonk over 3 years ago

Seems that it's only 1 file that needs to be put back and 1 file to patch as per http://git.kernel.org/cgit/network/connman/connman.git/log/

Should be easy enough to implement.

Updated by Herman van Hazendonk about 2 years ago

  • % Done changed from 0 to 50

Seeing we'll be on 3.4 now with all supported targets this should get feasible to look into.

Updated by Herman van Hazendonk about 1 month ago

  • Status changed from New to Closed
  • Target version changed from Later to Decaf
  • % Done changed from 50 to 100

Solved with previous release.

Also available in: Atom PDF