Content

Bug #1085

Luna Next restart loses the system menu

Added by Ian Miller over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:01/25/2016
Priority:Normal Due date:
Assignee:Christophe Chapuis % Done:

100% Total progress

Category:System Services
Target version:Coffee Milk

Description

Boot. Tap the top right corner of the display. Get a system menu displayed with date, battery brightness, etc.

Bring up the power option buttons and press Luna Next restart. Wait for it to come back. Tap the top right corner of the display. Nothing. (You can't hold the power button to bring the power option buttons up either.)


Issue Hierarchy ()

History

Updated by Herman van Hazendonk over 3 years ago

  • Assignee set to Herman van Hazendonk
  • Status changed from New to In Progress

Able to replicate on latest nightly on N4. Will check logs to see what's going on.

Updated by Kyle Maas over 3 years ago

Unable to replicate in qemux86.

Updated by Herman van Hazendonk over 3 years ago

  • Target version changed from CafĂ© Miel to Coffee Milk

Updated by Ian Miller over 3 years ago

This issue seems to have gone away now.

Updated by Ian Miller over 3 years ago

But it is still there in the official build. How strange!

Updated by Herman van Hazendonk over 3 years ago

  • Assignee changed from Herman van Hazendonk to Christophe Chapuis

We also have:

Feb 07 07:45:47 maguro LunaSysMgr979: [] [pmlog] <default> LS_SIG_NREG {"URI":"palm://com.palm.display/com/palm/power/chargerStatusQuery"} _LSSignalSendCommon: Warning: you did not register signal palm://com.palm.display/com/palm/power/chargerStatusQuery via LSRegisterCategory().

Feb 07 07:45:47 maguro LunaSysMgr979: [] [pmlog] <default> LS_SIG_NREG {"URI":"palm://com.palm.display/com/palm/power/USBDockStatus"} _LSSignalSendCommon: Warning: you did not register signal palm://com.palm.display/com/palm/power/USBDockStatus via LSRegisterCategory().

Feb 07 07:45:47 maguro LunaSysMgr979: [] [pmlog] <default> LS_SIG_NREG {"URI":"palm://com.palm.display/com/palm/power/batteryStatusQuery"} _LSSignalSendCommon: Warning: you did not register signal palm://com.palm.display/com/palm/power/batteryStatusQuery via LSRegisterCategory().

It all seems to originate to a "wrong" state "startup" that's being returned by org.webosports.bootmgr after SOME LNC restarts.

Probably originates:

https://github.com/webOS-ports/luna-sysmgr/blob/webOS-ports/master/Src/base/DisplayManager.cpp#l954 & https://github.com/webOS-ports/luna-sysmgr/blob/webOS-ports/master/Src/base/DisplayManager.cpp#l329 which is too close to the other 3 errors we had in the log about the signals not being registered....

Updated by Herman van Hazendonk over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Feedback

Updated by Ian Miller over 3 years ago

I agree that this is now fixed (latest code).

Updated by Herman van Hazendonk over 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF