Content

Bug #1127

Emulator: Hardware keyboard doesn't work on additional windows (even when focussed)

Added by Herman van Hazendonk over 3 years ago. Updated almost 3 years ago.

Status:In Progress Start date:04/06/2016
Priority:Normal Due date:
Assignee:Nikolay Nizov % Done:

70% Total progress

Category:UI
Target version:Later

Description

When opening a new browser window and this browser window has focus, hardware keyboard doesn't work.

browser.txt (36.2 kB) Herman van Hazendonk, 08/31/2016 08:33 AM


Issue Hierarchy ()

History

Updated by Herman van Hazendonk over 3 years ago

  • Assignee set to Nikolay Nizov

Updated by Herman van Hazendonk over 3 years ago

  • Target version changed from Later to Tobio
  • % Done changed from 0 to 70
  • Category set to UI
  • Status changed from New to In Progress

It is partly solved with your PR, however it seems it's still a little buggy.

What I do:
1. Open Browser, go to address bar, VKB pops up, I type with HW KB.
2. I press the + for a new browser window.
3. HW KBD doesn't work now, nor I can select the address bar, since it seems focus is still on the first Browser window & address bar.

This might be related to http://issues.webos-ports.org/issues/1099

Updated by Herman van Hazendonk about 3 years ago

  • Target version changed from Tobio to Later

Updated by Herman van Hazendonk almost 3 years ago

The odd thing is that it only seems to be the case on the even number of tabs. Tab 1 works, tab 2 doesn't work, tab 3 works, tab 4 doesn't work, tab 5 works, tab 6 doesn't work etc.

Attached the logfile. I didn't see anything suspicious in there though.

Updated by Herman van Hazendonk almost 3 years ago

Tested previous maliit framework + plugins & latest qt5-qpa-hwcomposer-plugin from upstream, but those don't solve the issue.

Also available in: Atom PDF