Padlock is not shown when in First Use mode (Bug #1205)


Added by Herman van Hazendonk 11 months ago. Updated 3 months ago.


Status:New Start date:03/06/2017
Priority:Normal Due date:
Assignee:Herman van Hazendonk % Done:

0%

Category:UI
Target version:Later


History

Updated by Herman van Hazendonk 9 months ago

  • Target version changed from Cold Brew to Cortado

Updated by Herman van Hazendonk 6 months ago

  • Target version changed from Cortado to Later

Updated by Herman van Hazendonk 3 months ago

Some reference info for debugging on legacy on first boot:

com.palm.systemmanager/getBootStatus
Check the device boot status.
\subsection com_palm_systemmanager_get_boot_status_syntax Syntax:
\code {
"subscribe": boolean
}
\endcode
\param subscribe Set to true to receive events when boot status changes.
\subsection com_palm_systemmanager_get_boot_status_returns Returns:
\code {
"finished": boolean,
"firstUse": boolean,
"returnValue": boolean,
"subscribed": boolean
}
\endcode
\param finished Is boot sequence finished.
\param firstUse Is this the first time the device is booted.
\param returnValue Indicates if the call was succesful.
\param subscribed True if subscribed to receive boot status change events.
\subsection com_palm_systemmanager_get_boot_status_examples Examples:
\code
luna-send -n 1 -f luna://com.palm.systemmanager/getBootStatus '{ "subscribe": false }'
\endcode
Example response for a succesful call:
\code {
"finished": true,
"firstUse": false,
"returnValue": true,
"subscribed": false
}
\endcode
*/

Also available in: Atom PDF