luna-sysmgr: "Src/webbase/SysMgrWebBridge.h:7:20: fatal error: QtWebKit: No such file or directory" (Bug #261)


Added by Dwayne Fontenot almost 5 years ago. Updated over 4 years ago.


Status:Closed Start date:10/16/2012
Priority:Normal Due date:
Assignee:Martin Jansa % Done:

100%

Category:-
Target version:Affogato

Description

arm-webos-linux-gnueabi-g++ -march=armv7-a -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a8 --sysroot=/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna -c -pipe -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -fvisibility-inlines-hidden -I/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna/usr/include -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -Wall -fpermissive -DFIX_FOR_QT -O2 -pthread -D_REENTRANT -Wall -W -Wno-unused-parameter -Wno-unused-variable -Wno-reorder -Wno-missing-field-initializers -Wno-extra -DQT_WEBOS -DSHIPPING_VERSION=0 -DMACHINE_TUNA -DMACHINE_PUBLIC_QUIRKS -DTARGET_DEVICE -DHAVE_LUNA_PREF=1 -DPALM_DEVICE -DQT_PLUGIN -DQT_STATICPLUGIN -DHAVE_QPA -DHAVE_OPENGL -DP_BACKEND=P_BACKEND_SOFT -DQT_NO_DEBUG -DQT_NO_KEYWORDS -DQT_DECLARATIVE_LIB -DQT_WEBKIT_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../../../sysroots/tuna/mkspecs/qws/linux-armv6-g++ -I. -I../../../../sysroots/tuna/include/QtCore -I../../../../sysroots/tuna/include/QtNetwork -I../../../../sysroots/tuna/include/QtGui -I../../../../sysroots/tuna/include/QtOpenGL -I/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna/include/QtWebKit -I../../../../sysroots/tuna/include/QtDeclarative -I../../../../sysroots/tuna/include -ISrc -ISrc/base -ISrc/base/application -ISrc/base/hosts -ISrc/base/visual -ISrc/base/gesture -ISrc/base/windowdata -ISrc/base/settings -ISrc/core -ISrc/js -ISrc/sound -ISrc/webbase -ISrc/lunaui -ISrc/lunaui/cards -ISrc/lunaui/notifications -ISrc/lunaui/emergency -ISrc/lunaui/lockscreen -ISrc/lunaui/dock -ISrc/minimalui -ISrc/remote -ISrc/lunaui/status-bar -ISrc/ime -ISrc/nyx -ISrc/lunaui/launcher -ISrc/lunaui/launcher/gfx -ISrc/lunaui/launcher/gfx/debug -ISrc/lunaui/launcher/gfx/pixmapobject -ISrc/lunaui/launcher/gfx/effects -ISrc/lunaui/launcher/gfx/processors -ISrc/lunaui/launcher/physics -ISrc/lunaui/launcher/physics/motion -ISrc/lunaui/launcher/elements -ISrc/lunaui/launcher/elements/page -ISrc/lunaui/launcher/elements/page/icon_layouts -ISrc/lunaui/launcher/elements/bars -ISrc/lunaui/launcher/elements/icons -ISrc/lunaui/launcher/elements/util -ISrc/lunaui/launcher/elements/static -ISrc/lunaui/launcher/elements/buttons -ISrc/lunaui/launcher/systeminterface -ISrc/lunaui/launcher/systeminterface/util -ISrc/lunaui/launcher/util -ISrc/lunaui/launcher/test -I../../../../sysroots/tuna/usr/include/glib-2.0 -I../../../../sysroots/tuna/usr/include/webkit -I/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna/usr/include/QtWebKit -I../../../../sysroots/tuna/usr/include/webkit/npapi -I../../../../sysroots/tuna/usr/include/sysmgr-ipc -I../../../../sysroots/tuna/usr/include/freetype2 -I/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna/usr/include/PmLogLib/IncsPublic -I/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna/usr/include/napp -I../../../../sysroots/tuna/usr/include/ime -I../../../../sysroots/tuna/usr/lib/glib-2.0/include -I/mnt/sda9/packages/woce-gnex-02/webos-ports-env/webos-ports/tmp-eglibc/sysroots/tuna/usr/include -Irelease-tuna/.moc -o release-tuna/.obj/WebAppCache.o Src/webbase/WebAppCache.cpp
In file included from Src/webbase/WebAppBase.h:22:0,
from Src/webbase/WebAppCache.cpp:27:
Src/webbase/SysMgrWebBridge.h:7:20: fatal error: QtWebKit: No such file or directory
compilation terminated.


History

Updated by Martin Jansa almost 5 years ago

The problem is for sure in qt4-webos recipe, it does not stage any headers now. Don't know why yet, but now there is only 1 header file
tmp-eglibc/sysroots/tuna/usr/include/QtOpenGL all a few dirs but no QtWebKit.

It could be fault of recipes-webos/qt4/qt4-webos.bbappend do_install_append_tuna override or something else.. will debug a bit more tomorrow.

Updated by Dwayne Fontenot almost 5 years ago

FYI, I've looked back at my build dirs going back > 10 days and none of them have tmp-eglibc/sysroots/tuna/usr/include/QtWebKit .
Is it something new?

Updated by Martin Jansa almost 5 years ago

There are 3 separate issues

1) Current webos-ports qt4-webos build provides only 1 header file (where it should be directory)
tmp-eglibc/sysroots/tuna/usr/include/QtOpenGL
2) Newer meta-webos with qt4-native I've in jansa/master branch, provides all common header files in right directories (but with QtWebKit still missing and disabled during configure)
and this solution will take a bit longer to finish (now fixing webkit-webos).
3) qt4-webos wasn't using sstate properly.. so those header files are not removed with -c cleansstate. On jenkins we have them from "Oct 11 16:04", so it worked back then but could be from even older sstate package (for which we don't keep history).

And because on my local workstation I'm working on 2) I have to use slower jenkins machines to debug this.

Looking at luna-sysmgr history, this need for QtWebKit is not new (at least in SysMgrWebBridge.h, not sure if webbase was built before in luna-sysmgr).

Updated by Martin Jansa almost 5 years ago

I was wrong assuming that QtWebKit headers are installed through qt4-webos (like in oe-core with qt4-embedded and qt4-x11-free, where I had similar issue http://lists.linuxtogo.org/pipermail/openembedded-core/2012-September/030551.html)

They are added to sysroot by webkit-webos recipe and again without proper use of sstate, so as work around do:

bitbake -c cleansstate -f webkit-webos luna-sysmgr; bitbak -k luna-sysmgr;

I'll remove webkit-webos from sstate-cache (like qt4-webos) as work around, but will keep this bug open until it's resolved properly.

Updated by Dwayne Fontenot almost 5 years ago

I can confirm that the workaround works.

Updated by Simon Busch almost 5 years ago

  • Target version deleted ()
  • Status changed from New to In Progress

Updated by Martin Jansa almost 5 years ago

Patches to fix this applied upstream, rsync jobs on jenkins updated to not remove qt4-webos and webkit-webos from sstate now.

  • Status changed from In Progress to Resolved

Updated by Simon Busch over 4 years ago

  • Target version set to Affogato

Updated by Tom King over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Resolved to Closed

Also available in: Atom PDF