App unsuccessful at obtaining media indexer database permssions (Bug #637)


Added by Doug Reeder about 3 years ago. Updated about 3 years ago.


Status:Closed Start date:09/25/2014
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-

Description

When my app (Zap Photoshare) calls palm://com.palm.mediapermissions to get read permissions for "com.palm.media.image.album:1" and "com.palm.media.image.file:1", the following errors are logged:
Sep 25 04:42:12 tenderloin ls-hubd939: Could not get permissions from db. Reason: No or too many permission sets for appId com.hominidsoftware.zapphotoshare
Sep 25 04:42:12 tenderloin ls-hubd939: Error: palm://org.webosports.luna/publishToSystemUI {"event":"mediaFilePermissionRequest","message":{"action":"requestPermission","rights":{"read":["com.palm.media.image.album:1","com.palm.media.image.file:1"]},"senderId":"com.hominidsoftware.zapphotoshare","sessionId":0,"replyTo":"palm://com.palm.mediaper

and the call returns the error "Schema validation error".


History

Updated by Tom King about 3 years ago

Placed in Wrong Project

  • Project changed from LunaCE to LuneOS
  • Target version deleted (Palm-LunaSysMgr)

Updated by Achim Königs about 3 years ago

Looking into this...

First result:
The messages you posted are not related and are more or less expected. The first happens because your app does not have permissions, yet. Execution after that continues ok. The second happens, because the UI part is not ready, yet. This is also caught in the service and rights are automatically granted, so execution continues.

Schema error might come from db8? Not sure... Could you give me the request you send? I tried to reproduce this, but did not manage to.

  • Assignee set to Achim Königs
  • Status changed from New to Feedback

Updated by Achim Königs about 3 years ago

Ok, got your app from the app catalog. It seems to me that the permissions are granted. At least in the testing builds... but permission service has not changed for some time.

Updated by Doug Reeder about 3 years ago

Thanks! (If you need the .ipk for any of my apps, just ask.)

When I run Zap now, it is able to retrieve the list of albums; currently "wallpapers" and "internal". (I'm not certain whether this was happening before and I failed to observe it.) So it looks like this issue can be closed.

I'm trying to understand what's going on in my app, but I can't make use of the directions at http://webos-ports.org/wiki/Luna_Next_Remote_WebApplication_Debugging because the command webapp-launcher does not appear to exist.

  • Assignee deleted (Achim Königs)

Updated by Doug Reeder about 3 years ago

Okay the problem is the media indexer is returning an albumPath property, and I’m expecting path.
https://developer.palm.com/content/api/reference/data-types/media-indexer.html#albumimage says there's a "path" property (which indeed is returned under webOS).

LuneOS appears to return a "albumPath" property with that info.

Updated by Doug Reeder about 3 years ago

Fixed by a commit yesterday.

Updated by Doug Reeder about 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF