Content

Bug #897

Display won't turn on after long time of idle

Added by Achim Königs over 4 years ago. Updated over 3 years ago.

Status:Closed Start date:04/29/2015
Priority:Normal Due date:
Assignee:Christophe Chapuis % Done:

100% Total progress

Category:UI
Target version:Mocha

Description

Here is what I did:
1. flash N4 with testing build 145 (this should be the image from April 21st, will retry April 25th image now)
2. Use N4 for some testing
3. Turn of the display using the power button
4. Let N4 lay around > 1 hour without power supply

Now, when I press the power button nothing happens.
I connected the N4 to a computer and got a log using adb, which is here:
https://bpaste.net/show/cc6f9885c9a2

I tried to restart all kind of services, including luna-next, but that did not help. The only way I found to get it working again is to (hard) reboot the device.


Issue Hierarchy ()

History

Updated by Simon Busch over 4 years ago

  • Target version set to Bombon
  • Assignee set to Simon Busch
  • Category set to UI

luna-next seems to hang and can't change the display state which leads to luna-sysmgr waiting for ever for the response of its call to luna://org.webosports.luna/setDisplayState '{"state":"on"}'

syscall () at ../sysdeps/unix/sysv/linux/arm/syscall.S:37
37        swi    0x0
(gdb) bt
#0  syscall () at ../sysdeps/unix/sysv/linux/arm/syscall.S:37
#1  0x40db5c78 in QBasicMutex::lockInternal() () from /usr/lib/libQt5Core.so.5

Updated by Simon Busch over 4 years ago

  • % Done changed from 0 to 10
  • Status changed from New to In Progress

Updated by Herman van Hazendonk over 4 years ago

  • Target version changed from Bombon to Cubano

Updated by Doug Reeder over 4 years ago

On my N4, I observe that, after being idle for a while, the unit is unresponsive. It's usually plugged into USB, so a normal screen is displayed. But I observe it with the device unplugged as well.

Updated by Herman van Hazendonk over 4 years ago

I can confirm that as well. Screen either doesn't come back on, or it's "stuck" in a certain screen.

Updated by Herman van Hazendonk over 4 years ago

  • Target version changed from Cubano to Crema

Updated by Herman van Hazendonk over 4 years ago

  • Target version changed from Crema to Later

Updated by Herman van Hazendonk about 4 years ago

  • Target version changed from Later to Marocchino
  • Assignee changed from Simon Busch to Christophe Chapuis

Seems to be due to DBUS getting flooded. System is still active, just display doesn't come up again. Not solved with update to QT 5.5

Updated by Herman van Hazendonk about 4 years ago

  • Target version changed from Marocchino to Medici

Updated by Herman van Hazendonk almost 4 years ago

  • Target version changed from Medici to Café Miel

Updated by Herman van Hazendonk almost 4 years ago

  • Target version changed from Café Miel to Later

Waiting for QT 5.6 release

Updated by Herman van Hazendonk over 3 years ago

  • Target version changed from Later to Mocha
  • % Done changed from 10 to 50

Seems it might finally be solved with QT 5.6 upgrade.

Updated by Herman van Hazendonk over 3 years ago

  • % Done changed from 50 to 100
  • Status changed from In Progress to Closed

Seems solved after 5.6 update

Also available in: Atom PDF