Content

Bug #953

App windows randomly don't appear

Added by Herman van Hazendonk over 4 years ago. Updated about 4 years ago.

Status:Closed Start date:08/13/2015
Priority:Normal Due date:
Assignee:Christophe Chapuis % Done:

100% Total progress

Category:UI
Target version:Marocchino

Description

Email app started, but no window visible. Log attached.

out.txt (690.1 kB) Herman van Hazendonk, 08/13/2015 07:38 PM


Issue Hierarchy ()

History

Updated by Herman van Hazendonk over 4 years ago

  • Target version changed from Olla to Latte

Updated by Christophe Chapuis over 4 years ago

One interesting error in the log could be :
Aug 13 16:04:08 mako LunaWebAppManager1508: file:///usr/palm/applications/com.palm.app.email/util/MojoDBChangeProcessor.js:345: CONSOLEAPI LOG: Exception caught while processing changes for com.palm.folder:1. Error stack: Oop.js: Failed to find a constructor for kind [enyo.PalmService]

Maybe this Enyo1 app has difficulty to find the PalmService we propose via WebView ?

Updated by Herman van Hazendonk over 4 years ago

It might actually be related to other app windows not closing properly/timing out. I guess when the luna-webappmanager issues have been sorted it will behave more properly.

Updated by Herman van Hazendonk about 4 years ago

  • Target version changed from Latte to Marocchino

Updated by Herman van Hazendonk about 4 years ago

  • % Done changed from 0 to 50
  • Status changed from New to In Progress

While migrating to QtWebEngine we ran into the same issue. Seems it has to do with the timing of loading the UserScripts. We need to find a way to make sure they're loaded before we try load the app.

Updated by Herman van Hazendonk about 4 years ago

  • % Done changed from 50 to 100
  • Status changed from In Progress to Feedback

Updated by Herman van Hazendonk about 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF